New minimum requirements in WooCommerce 3.7

With the upcoming release of WooCommerce 3.7 we will be updating the minimum required versions of WordPress and PHP. In order to update and run WooCommerce 3.7 you will now be required to have at least WordPress 4.9 and PHP 5.6.

We have to do this to keep up with the code changes within the WordPress ecosystem and to be able to deliver the best experience for our users.

The good news is that according to our research only a very very small percentage of stores are running these outdated versions so the impact will be minimal. What does it mean for your store if affected? Simply put you will not be able to update to WooCommerce 3.7 when it gets released, WordPress will not offer you the update.

We have created a document explaining the details around why updating to newer versions of WordPress and PHP is beneficial and included instructions on how to safely update.

If you have any questions or feedback around the decision and work related to this update, please feel free to leave them in the comments.

10 responses to “New minimum requirements in WooCommerce 3.7”

  1. Definitely approve of this change.

    Just curious – what percentage of stores are affected? 10%, 1%, 0.1%?

    “very small” can mean a lot of things. 🙂

    1. Gerhard Potgieter Avatar
      Gerhard Potgieter

      In the lower single digits.

  2. What’s the target release date for 3.7.0?

    Will 3.6.5 precede that? or be skipped in favor of rolling it into 3.7.0?

    1. Gerhard Potgieter Avatar
      Gerhard Potgieter

      We will continue with fix releases and 3.5.6 is scheduled for this week still. Regarding the date for 3.7, that will likely be in a month’s time. More details will be posted soon.

  3. doctorhacker Avatar

    Hello! And in which release of VooKommerts you plan to introduce the concept of templates for the product editor. The prototype you previously described here:
    I look forward to it. Thank you very much!

    1. doctorhacker Avatar

      Please answer my question.

  4. doctorhacker Avatar

    I’m sorry. Fixed: VooKommerts* – WooCommerce

  5. Will WordPress simply not show the update at all, or will it be shown with information encouraging an update of PHP?

    1. Gerhard Potgieter Avatar
      Gerhard Potgieter

      It will show the update but won’t allow you to update with a message saying it is not compatible.

  6. rdrg520eshs Avatar

    Hello, since I did the update I cannot get Square to sync. I have disconnected and re-connect but it still does not want to work, can you help?

Leave a Reply

Your email address will not be published. Required fields are marked *