Categories
Core

WooCommerce 4.7 is now available!

We are excited to announce that WooCommerce 4.7 is now publicly available! It has been in development since October 2020 and has been updated with 393 commits from 22 contributors.

This is a minor release, which means everything is backward compatible with the previous version.

Black Friday is coming up and we’re keeping this release small, focusing on stability and compatibility, with most of the updates being fixes.

As always, we recommend creating a backup of your site and making sure that themes and plugins are compatible before updating. You can check out this update guide for more information.

What’s new in 4.7?

The WooCommerce 4.7 release contains updated versions of WooCommerce Admin (1.6.3) and WooCommerce Blocks (3.5.0 & 3.6.0), fixes, and localization improvements.

Notable fixes and improvements

  1. Updated product_cat/tag taxonomy template file names to product-cat, and product-tag. (#27736).
  2. Excluded draft pages from the “Shop page” setting. (#27890).

You can review the complete changelog for this release on the changelog.txt file.

Filters and actions

We have added one new filter:

FiltersDescription
woocommerce_should_send_low_stock_notificationDetermine if the current product should trigger a low stock notification..

Database changes

This release does not introduce any changes to the database.

Template changes

Several files were added or updated in this release, including:

FileDescription
content-product-cat.phpNew file introduced by #27736 to replace content-product_cat.php
taxonomy-product-cat.phpNew file introduced by #27736 to replace taxonomy-product_cat.php
taxonomy-product-tag.phpNew file introduced by #27736 to replace taxonomy-product_tag.php

Note that content-product_cat.php, taxonomy-product_cat.php, and taxonomy-product_tag.php are still supported by WooCommerce.

Much 💜 to all the contributors

Finally a big thanks to everyone in the community who has contributed via issue reports, fixestranslation, testing, supporting other users or simply spreading the word.

WooCommerce Core

claudiosanches rodrigoprimo rrennick Konamiman shiki roykho
claudiosanches rodrigoprimo rrennick Konamiman shiki roykho
ObliviousHarmony haszari vedanshujain juliaamosova timmyc dominic-ks
ObliviousHarmony haszari vedanshujain juliaamosova timmyc dominic-ks
peterfabian tammullen james-allan sudoshreyansh Knyazevich Luminus
peterfabian tammullen james-allan sudoshreyansh Knyazevich Luminus
Rowayda-Khayri Aljullu NicholasMacedo pjv jondcampbell kloon
Rowayda-Khayri Aljullu NicholasMacedo pjv jondcampbell kloon
om4james jozeflambrecht ibonkonesa
om4james jozeflambrecht ibonkonesa

WooCommerce Admin

joshuatf becdetat psealock joelclimbsthings octaedro timmyc
joshuatf becdetat psealock joelclimbsthings octaedro timmyc
samueljseay jeffstieler ecgan moon0326 adrianduffell dechov
samueljseay jeffstieler ecgan moon0326 adrianduffell dechov
mattsherman zzap rtpHarry rrennick
mattsherman zzap rtpHarry rrennick

WooCommerce Blocks

nerrad Aljullu senadir budzanowski haszari mikejolley
nerrad Aljullu senadir budzanowski haszari mikejolley
kloon corsonr farookibrahim
kloon corsonr farookibrahim

Action Scheduler

rrennick
rrennick

By Claudio Sanches

Developer on the WooCommerce team and member of the WordPress Brazilian community.

6 replies on “WooCommerce 4.7 is now available!”

I bought the e-commerce version of WordPress.com and it has that version of WooCommerce. I’m trying to use Sensei Paid Courses to associate the products with the courses, but I can’t because the plugin doesn’t work. It says in the ‘State’ tab of WooCommerce that installed version is not tested with the active version of WooCommerce 4.7.0

In a total of 20 plugins, including Facebook for WooCommerce and Google Ads.

Any advice to get them working?

Like

Hello, there’s no major changes in 4.7.0, and plugins should keep working like before even that plugin developers didn’t updated to say that is compatible with 4.7. Note this mensage doesn’t say that is incompatible or doesn’t work, it just say if is tested or not, so you can use even if it says that isn’t compatible for now before plugin developers update it.
I hope it helps.

Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.