Critical Vulnerability in Multiple Versions of WooCommerce


A critical vulnerability was detected in multiple versions of WooCommerce and the WooCommerce Blocks feature plugin.  Patches for each impacted version have been created and deployed automatically to vulnerable stores..

The details

A security vulnerability in WooCommerce and WooCommerce Blocks was recently discovered and reported to us via our HackerOne security program by security researcher Josh. This vulnerability can result in data such as user IDs and hashed passwords being exposed.

Upon learning about the vulnerability, WooCommerce teams took immediate steps to conduct a thorough investigation, audit related code bases, and create a patch fix for 90+ impacted releases.  This patch was deployed to vulnerable stores automatically.

Our investigation into this vulnerability and whether data has been compromised is ongoing. We will be sharing more information with site owners on how to investigate this security vulnerability on their site, which we will publish on our blog when it is ready. If a store was affected, the exposed information will be specific to what that site is storing but could include order, customer, and administrative information.

There is additional information available in the recent announcement on the WooCommerce Blog.

How can I tell if this affects me?

This vulnerability affects releases of WooCommerce Blocks ranging from version 2.5 through version 5.5 and WooCommerce core versions 3.3 through version 5.5.  Any stores running a version of WooCommerce or WooCommerce Blocks within these ranges is considered vulnerable.

What action should I take?

While security patches are being deployed automatically to vulnerable stores, we still recommend updating to the latest version of these plugins, which is currently 5.5.1.

10 responses to “Critical Vulnerability in Multiple Versions of WooCommerce”

  1. […] efter WooCommerce 5.5.0 släpps så tvingas WooCommerce-utvecklarna att släppa en ny uppdatering. 5.5.1 är ute nu, och sannolikt har du redan uppdaterats till den om du redan var på 5.5.0 – uppdateringen var […]

  2. […] 15/7/2021 (τοπική ώρα), ανακοινώθηκε από το ένα σοβαρό(critical) κενό ασφαλείας.. Ως τώρα (μεσημέρι 15/7/2021) που δημοσιεύεται αυτό το […]

  3. thank you for the information

  4. […] The WooCommerce team has also posted more information about this incident on their blog. […]

  5. The WooCommerce team works regularly. Thanks to @Josh and @WooCommerce team.

  6. […] Developer Advisory: Critical Vulnerability in Multiple Versions of WooCommerce […]

  7. […] 5.5 have also been released. has the ability to push out automatic plugin updates for security reasons so if you were running version 5.4.1 it would have automatically updated to version […]

  8. […] issues and fixes several bugs identified in 5.5.0 and 5.5.1. These updates are unrelated to the recent security vulnerability that was solved by WooCommerce […]

  9. […] issues and fixes several bugs identified in 5.5.0 and 5.5.1. These updates are unrelated to the recent security vulnerability that was solved by WooCommerce […]

  10. thank you josh and woocomerce team

Leave a Reply

Your email address will not be published. Required fields are marked *