Categories
WooCommerce Core

New Requirement for WooCommerce 7.7: PHP 7.3+

The minimum PHP version required for WooCommerce was bumped from 7.0 to 7.2 in WooCommerce 6.5 in May 2022. Exactly one year later WooCommerce will take the next step: starting with version 7.7, scheduled for release in May 2023, WooCommerce will require PHP 7.3 or newer to work.

Why this change?

As we said in the announcement post for the bump to 7.2, the PHP ecosystem is evolving rapidly. At the time of writing this PHP 8.2 has already been released, and PHP 7.4, the most widely used PHP version for WooCommerce by leaps and bounds, has reached its end of official support date. Newer PHP versions are more performant and more secure, but the problem is not only PHP itself: supporting old PHP versions often means sticking to old versions of packages and other external dependencies.

This is the current (January 2023) graph of PHP versions usage for WooCommerce based on the data we have:

If you compare this with the graph in the post for the PHP 7.2 bump you’ll see that proportionately, the usage for PHP 7.2 is roughly the same that PHP 7.1 and 7.0 had combined back then. We said in a comment in that post that we would consider a bump to PHP 7.3 when reaching that point, and that’s what we did.

Moving forward: PHP 7.4

Another thing that stands out from the graph above is that PHP 7.4 greatly outweighs all the older versions: 7.3 shows a proportional usage that is even smaller, compared to 7.4, than what 7.2 had one year ago. It’s also interesting to see how PHP 8 is slowly gaining ground, which is a good thing.

Given that, we have decided that most likely we won’t wait another year for the next step. Our current plan is to bump the PHP requirement for WooCommerce to 7.4 at some point in the second half of 2023, of course depending on the usage numbers we see in half a year from now, and with the proper advance notice.

What happens if I don’t upgrade?

If your server is still on PHP 7.2 by the time WooCommerce 7.7 is published, your WooCommerce instance will continue working, but you won’t be able to upgrade past WooCommerce 7.6 (or any 7.6.x maintenance release published afterwards).

We strongly recommend that you run an up to date and supported version of PHP. As of right now, that includes PHP 8.0 and newer versions. The latest versions of PHP bring numerous performance improvements and ensure that your site is secure.

By konamiman

MSX lover since 1986. Automattician since March 2020.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.