Categories
WooCommerce Core

New requirement for WooCommerce 6.5: PHP 7.2+

It’s been a while since we bumped the minimum PHP version of WooCommerce to 7.0, and it is about time for a new bump. Starting with version 6.5, scheduled for release in May 2022, WooCommerce will require PHP 7.2 or newer to work.

Why this change?

The PHP ecosystem is evolving rapidly. At the time of writing this, the only actively maintained versions of PHP are 8.0 and 8.1; PHP 7.4 entered “security fixes only” mode and PHP 7.3 went unsupported as of December 2021. WordPress recommends at least PHP 7.4 for performance and security reasons, and these reasons are even more important on an e-commerce site.

WooCommerce also depends on a number of third-party packages — and many of those are gradually dropping support for older PHP versions. This is already causing issues, as it’s increasingly hard to find packages that support all the range of PHP versions from 7.0 to 8.1.

Why 7.2 specifically? This is the oldest version that still has a significant number of WooCommerce installs running according to our data:

Note that of all the sites running on PHP 7.0 or 7.1, only about half seem to be actively maintained — that is, running a WooCommerce version that is at most six months old.

What happens if I don’t upgrade?

If your server is still on PHP 7.0 or 7.1 by the time WooCommerce 6.5 is published, your WooCommerce instance will continue working, but you won’t be able to upgrade past WooCommerce 6.4 (or any 6.4.x maintenance release published afterwards).

We strongly recommend upgrading your servers to at least PHP 7.4 in order to keep your WooCommerce sites up to date, performant, and secure.

By konamiman

MSX lover since 1986. Automattician since March 2020.

10 replies on “New requirement for WooCommerce 6.5: PHP 7.2+”

For what is worth, I agree with the change in requirements. I tried to keep backward compatibility as much as I could, and my plugins still support WooCommerce 3.0, but I bumped the PHP requirements to 7.1. Leaving aside the critical security patches, newer versions include useful features that make the code easier to write an maintain, so thumbs up from me. 👍

Liked by 1 person

“Note that of all the sites running on PHP 7.0 or 7.1, only about half seem to be actively maintained — that is, running a WooCommerce version that is at most six months old.”

Out of interest, where do you get these statistics from? As far as I know, this can’t be worked out from the publicly-available wordpress.org statistics.

Like

Totally agree with Diego. As third party devs we welcome the min req bump for PHP to 7.2.

Approximately 89% of installs we see are already on 7.3 or higher and 95% are on 7.2 or higher. Very minimal installs using 7.1 or 7.0 (less than 1.5%) and even less below that.

Forgive me to grabbing the soap box but the more pressing/bigger issue that we’re seeing is the huge distribution of active WooCommerce versions out in the wild.

Only 25% of our users are on 6.0 and we still see significant numbers of users on versions as old as 5.2.

You can see this reflected in the public .org stats on WooCommerce too:
https://wordpress.org/plugins/woocommerce/advanced/ (note the 58.5% “other”)

I feel like more needs to be done to educate store owners on why they should keep their installs up to date. We do our part in educating our users, but its a drop in the ocean compared to what the Woo core team could do.

For a lot of store owners, the general feeling is that hitting the update button is risky as and causes massive disruption and breaks parts of their store. This is largely not the case anymore (it used to be which is why there’s the perception still).

Because the updates come every month, pretty soon we (the broader Woo/WP dev community) will be facing store owners that have up to 2 years worth of lagging updates.

Liked by 1 person

Thanks for sharing. We very much try to do that, that’s why we’ve also ramped up our testing considerably and shared it with the community (e.g. https://dothewoo.io/julie-amosova-walks-through-the-testing-of-woocommerce-releases/) to increase the trust of merchants in the updates. I agree, though, that we should be doing more.

Our stats show that this has been improving, at least for active stores (i.e. those that show the number of orders increasing at least once a month). For those, I can see that 40% are on 6.0 and 72% are on 5.8+, which is not too bad for a mid-December release I’d say. I think the .org stats show also a lot of zombie stores that have no real activity.

That said, we’d be happy to discuss your experience with users and potential ideas for moving more stores towards staying up to date. I’ll reach out in the Community Chat Slack if that’s fine.

Liked by 1 person

Of course Peter! Happy to chat any time 🙂 I’m all about sharing the community love and our whole team is committed to making not just our products better but the whole experience for store owners. Its always win-win.

Liked by 2 people

7.2+???
Are you kidding?
7.2 and 7.3 are both over the EOL.
If you are serious web developer you don’t have to encourage the usage of high potential insecure products.

Like

Hi Diogene, thanks for your comment. I’m the author of the post and possibly the strongest advocate for required PHP version bumps inside the WooCommerce team in Automattic.

you don’t have to encourage the usage of high potential insecure products

We don’t. In fact, the last sentence in this post is “We strongly recommend upgrading your servers to at least PHP 7.4 in order to keep your WooCommerce sites up to date, performant, and secure”.

However you’ll see in the included graph that PHP 7.2 and 7.3 servers still account for about one third of all the WooCommerce installs. We need to maintain a balance between keeping WooCommerce robust and secure and disrupting the least amount of users that is reasonably possible, and given that, a bump to PHP 7.2 is the farthest we find appropriate to go at this point.

We revisit these numbers periodically, and whenever 7.2/.3 reach the numbers currently shown by 7.0/.1 we’ll consider a bump to 7.4.

Liked by 2 people

I agree with your philosophy. Besides, there’s not only WooCommerce, but also thousands of themes and plugins that might not work properly with PHP 7.4, even though that should be the recommended minimum version. One can’t adopt a “latest version, always” requirement, as that could cause an avalanche of errors in the ecosystem.

Even if these errors were due to other developers not keeping up with the changes in newer PHP versions, one also couldn’t just shrug them off with a “blame the other developers who don’t keep up” while the sites are unusable. Due to that, backward compatibility is required, hence the decision to go back up until 7.2.

For the record, I would have liked to use PHP 7.0 as soon as it came out, but there were so many merchants who ran their site on earlier versions that I had to stick to a minimum requirement of PHP 5.3 for quite a while (and it was already a problem, because, back then many used PHP 5.2). I bumped the minimum requirement to PHP 5.6 no about two years ago, and to 7.1 last year, because I couldn’t wait any longer, but I still see the occasional error caused by 3rd party elements that don’t keep up. As they say, “it is what it is”.

Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.