Categories
blocks Core

Developer Advisory: Critical Vulnerability in Multiple Versions of WooCommerce

tl;dr

A critical vulnerability was detected in multiple versions of WooCommerce and the WooCommerce Blocks feature plugin.  Patches for each impacted version have been created and deployed automatically to vulnerable stores..

The details

A security vulnerability in WooCommerce and WooCommerce Blocks was recently discovered and reported to us via our HackerOne security program by security researcher Josh. This vulnerability can result in data such as user IDs and hashed passwords being exposed.

Upon learning about the vulnerability, WooCommerce teams took immediate steps to conduct a thorough investigation, audit related code bases, and create a patch fix for 90+ impacted releases.  This patch was deployed to vulnerable stores automatically.

Our investigation into this vulnerability and whether data has been compromised is ongoing. We will be sharing more information with site owners on how to investigate this security vulnerability on their site, which we will publish on our blog when it is ready. If a store was affected, the exposed information will be specific to what that site is storing but could include order, customer, and administrative information.

There is additional information available in the recent announcement on the WooCommerce Blog.

How can I tell if this affects me?

This vulnerability affects releases of WooCommerce Blocks ranging from version 2.5 through version 5.5 and WooCommerce core versions 3.3 through version 5.5.  Any stores running a version of WooCommerce or WooCommerce Blocks within these ranges is considered vulnerable.

What action should I take?

While security patches are being deployed automatically to vulnerable stores, we still recommend updating to the latest version of these plugins, which is currently 5.5.1.

By Allen Smith

I'm a dad who loves telling stories, connecting people, and making the world a better place.

9 replies on “Developer Advisory: Critical Vulnerability in Multiple Versions of WooCommerce”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.